Monday, March 17, 2014

Modifying a 75 ohm HP 85046B S-Parameter Test Set to be 50 ohms


A while ago I purchased an HP 8753A Network Analyzer to replace the HP 8505A Analyzer that I had been using in my home lab.  But I'd been delaying putting it into that rack where the 8505A has been, because I first wanted to get a 50-ohm S-Parameter test set for it.

The thing is, S-Parameter Test Sets for the 8753A, such as the 85046A, are expensive, and I'm cheap.

Recently I visited a friend, Dick (W1QG), who also has an 8753 Network Analyzer, and he showed me how he had modified a less-expensive 8503A (the S-Parameter test set for the 8505A analyzer) to work with the 8753.

He had added a latch and a one-shot to the 8503A (to generate the 200 msec Sweep-Delay signal for the 8753), and the circuit looked straight-forward and easy to implement. 

Dick mentioned, too, that although the 8503A is only spec'd to 1.3 GHz, he could operate his up to around 2 GHz with minor correction factors.

Sounded like a good approach.  And I had an 8503A.

The next day, though, happened to be the De Anza swapmeet in Cupertino.  And while walking its aisles I came across an 85046B S-Parameter Test Set.

Although directly compatible with my 8753A Network Analyzer (unlike my 8503A), this Test Set had a number of issues, the first being that it was 75, not 50, ohms.  Also, the seller told me that he'd removed its "Transfer Switch" (that's the coaxial relay inside it), and overall operating condition was unknown.

On the other hand...it was cheap!  And an idea hit me: rather than build the interface circuit that Dick had designed into my 8503A, would an easier approach be to somehow combine the 85046B's interface with my 8503A?

I had no idea if I could or couldn't, but the price was right, and I thought it would be fun to investigate.  So home it came with me.

Replacing the Missing Parts...

Fortunately, the Operating and Service Manual for the 85046A/B is available on the internet  ( Click here for manual).  Looking it over, it became clear that, with the exception of the 85046B's Bridge and Bridge/Splitter modules, everything else in the 75 ohm box was actually 50 ohms

I also noted that the 85043A/B had a 0-40 dB step attenuator (10 dB steps) that the 8503A did not have.

Comparing photographs in the 85046A/B and 8503A service modules, the Bridge and Bridge/Splitter modules looked very similar.

Hmmm...rather than modifying the 8503A to work with the 8753A, if I instead modified the 85046B to be 50 ohms, I'd already have (with no work on my part):
  1. A fully functional interface designed specifically for the 8753A.
  2. The 40 dB step attenuator.
And of course, it wouldn't hurt that the four N connectors for attaching the 85046 to the 8753 would properly line up with the 8753's four N connectors (unlike the 8503A).

It looked like all I needed to do would be to transfer the 50 ohm Bridge and Bridge/Splitter from the the 8503A to the 85046B!

Before I progressed further, though, I needed to replace the missing parts.  For the Transfer Switch (coaxial relay), I could have taken the one out of my 8503A, but that one was only rated to 1.5GHz (HP p/n: 08503-60035), while the proper one for the 85046A/B is rated to 18 GHz (HP 08503-60051).

Also, I discovered that one of the internal metal coax interconnect cables was missing. Fortunately, using the manual I found its part number (HP 85046-20009).  I Googled it and quickly found a company who could sell me both the cable and the Transfer Switch.

While they were in transit I looked over the 85046B manual further and discovered that there were two flavors of Logic boards; one board is designed to for use with a mechanical transfer switch (like the one I'd ordered), and the other is designed for use with a solid-state transfer switch.

The main difference between the two boards is the difference in the timing of the "Sweep-Delay" pulse generated for for the 8753 Network Analyzer whenever the Transfer Switch or Step Attenuator is changed (per this illustration):

(Click on Image to Enlarge)

Well, the board in my 85046B had a part number of 85046-60016.  Unfortunately, this was the board designed to work with  the solid-state transfer switch.  But I had the mechanical transfer switch, and so I really should be using the other logic board (HP 85046-60051) to create the proper 200 msec. Sweep-Delay pulse for the 8753A:

Fortunately, the PCB is common to both Logic boards, and there's only a slight difference in component values. Here's a summary of those differences:

        Solid-State Switch     Mechanical Switch
          (85046-60016)          (85046-60051)
   R7     39 ohms                  56 ohms (2 watts)
   C2     4,700uF, 35V         10,000uF, 35v 
   R25   0 ohms                    unstuffed
   R5     0 ohms                    unstuffed

So changing a -60016 board into a -60051 board couldn't be easier.  I just lifted one end on both R5 and R25 and called it a day.

(I lifted one end of each resistor, rather than removing the resistors entirely, so that I could easily convert the board back to its original state, should I ever need to.  And I didn't change R7 and C2 because they did not seem critical to me.  Given that the transfer switch's coil resistance is 200 ohms, I couldn't see a good reason to change R7 to 56 ohms.  And, although I would have replaced the 4,700uF cap with a 10,000uF cap if I'd had one, there wasn't one in my junk box. So I left it unchanged.)

Here's the new Transfer (Coaxial) Switch

Replacing the Bridge and Bridge/Splitter...

The next step was to remove the 75 ohm Bridge and Bridge/Splitter from the 85046B and replace them with the 50 ohm Bridge and Bridge/Splitter from my 8503A.  Here are the steps.  Apply to both the 85046B and the 8503A:
  1. Disconnect the SMA connectors attaching the RF plumbing to these two modules.
  2. Remove the four screws (and, where used, the four white shoulder-washers) holding each module to the chassis.
  3. Unplug from the PCB the single wire that goes to each box. 
Below is pictured one of the 75 ohm modules and one of the 50 ohm modules.  Physically they are identical (with the exception of the Test Port connectors on the right side, of course).

75 ohm unit from 85046B is on the top.
50 ohm unit from 8503A is on the bottom. 

I also moved the Blue and Gray wires from the 75 ohm boxes to the 50 ohms boxes (the wires attached to the 8503A modules are not long enough to attach to the Logic board in the 85046B).

And then I installed the 50 ohm Bridge and Bridge/Splitter into the 85046B, making sure that the modules were the appropriate side up so that the SMA connectors all aligned properly.

To summarize, if you have an 8503A gathering dust, using it to convert a 75 ohm 85046B to 50 ohms is very simple.  Here is all that I did:
  1. I replaced the 85046B's 75 ohm Bridge/Splitter (p/n 5086-7448) with the 50 ohm Bridge/Splitter (p/n 5086-7240) from my 8503A.  
  2. And I replaced the shorter yellow wire on the 5086-7240 with the longer Blue wire from the 5086-7448.
  3. I replaced the 85046B's 75 ohm Bridge (p/n 5086-7449) with the 50 ohm Bridge (p/n 5086-7229) from my 8503A.  
  4. And I replaced the shorter light-brown wire on the 5086-7229 with the longer Gray wire from the 5086-7449.
Here are the 50 ohm Bridge and Bridge/Splitter installed in the 85046B



A work in progress...
 



My initial testing (network analyzer not calibrated, so no correction factors have yet been applied)...

S11, open circuit:

S11, 50 ohm load

It seems to work!  I don't expect to get the full range of operation that an 85046A would give (to 3 GHz), because the 8503A modules are only spec'd to 1.3 GHz.  But, for me, this was a quick way to get an inexpensive, yet acceptable, S-Parameter Test Unit for my 8753A analyzer.

Addendum, 1 July 2015:

In the comments section below, David Kirkby,G8WRB mentioned a problem he had with the lid of the 8505A bridge missing the required four tapped mounting holes.  He sent along the following picture to illustrate the issue:





The unit on the left is the 75 ohm bridge from his 85046B.  Note the four mounting holes, circled in red on the case "lid".  This are missing from the 50-ohm 8505A unit on the right.

As Dave points out, the fix is straight-forward.  Just swap the two lids.

(I don't recall having this issue, myself.  But just in case I did and forgot about it, I'm glad Dave reported it.)



Caveats!

Standard caveats apply!  Know what you are doing.  Don't assume what I've written is correct -- I might have mistyped or made other mistakes.